Bump Erlang and RabbitMQ versions for 2020

parent 16bcd772
......@@ -71,7 +71,7 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
# export RABBITMQ_VERSION="3.7.14-alpha.11"
version: <%= ENV['RABBITMQ_VERSION'] %>
......@@ -91,7 +91,7 @@ suites:
rabbitmq:
erlang:
enabled: true
version: "21.3.8.16"
version: "23.0.2"
# export RABBITMQ_VERSION="3.7.13-alpha.21"
version: <%= ENV['RABBITMQ_VERSION'] %>
......@@ -110,7 +110,7 @@ suites:
erlang:
install_method: "esl"
esl:
version: "21.3.8.16-1"
version: "23.0.2-1"
rabbitmq:
# export RABBITMQ_VERSION="3.7.13-alpha.21"
version: <%= ENV['RABBITMQ_VERSION'] %>
......
......@@ -74,6 +74,15 @@ platforms:
intermediate_instructions:
- RUN yum -y install sudo lsof which systemd-sysv initscripts openssl net-tools
- name: ubuntu-20.04
driver:
image: dokken/ubuntu-20.04
pid_one_command: /bin/systemd
intermediate_instructions:
- ENV DEBIAN_FRONTEND noninteractive
- RUN /usr/bin/apt-get update -y
- RUN /usr/bin/apt-get install -y ca-certificates sudo apt-transport-https lsb-release procps net-tools
- name: ubuntu-18.04
driver:
image: dokken/ubuntu-18.04
......@@ -160,7 +169,7 @@ suites:
verifier:
inspec_tests:
- test/integration/default
includes: ["ubuntu-18.04", "ubuntu-16.04", "debian-10", "debian-9"]
includes: ["ubuntu-18.04", "ubuntu-20.04", "debian-10", "debian-9"]
- name: management-plugin-deb
run_list:
......@@ -170,9 +179,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/management_plugin
......@@ -187,9 +196,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
systemd:
limits:
NOFILE: 54000
......@@ -206,9 +215,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "21.3.8.16-1"
version: "23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -239,9 +248,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "21.3.8.16-1"
version: "23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
systemd:
limits:
NOFILE: 54000
......@@ -258,9 +267,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -275,9 +284,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -292,9 +301,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "21.3.8.16-1"
version: "23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -309,9 +318,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
attributes:
apt:
confd:
......@@ -320,9 +329,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -340,9 +349,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -364,7 +373,7 @@ suites:
erlang:
enabled: true
hipe: true
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/erlang_package/latest_deb
......@@ -379,8 +388,8 @@ suites:
rabbitmq:
erlang:
enabled: true
version: "1:21.3.8.16-1"
version: "3.7.26"
version: "1:23.0.2-1"
version: "3.8.5"
verifier:
inspec_tests:
- test/erlang_package/pinned_deb
......@@ -397,7 +406,7 @@ suites:
rabbitmq:
erlang:
enabled: true
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/erlang_package/latest_rpm
......@@ -412,11 +421,11 @@ suites:
rabbitmq:
erlang:
enabled: true
version: "21.3.8.16"
version: "23.0.2"
yum:
baseurl: https://dl.bintray.com/rabbitmq-erlang/rpm/erlang/21/el/7
repo_gpgcheck: true
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/erlang_package/pinned_rpm
......@@ -434,7 +443,7 @@ suites:
yum:
baseurl: https://dl.bintray.com/rabbitmq-erlang/rpm/erlang/21/el/6
repo_gpgcheck: false
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/erlang_package/latest_rpm
......@@ -449,11 +458,11 @@ suites:
rabbitmq:
erlang:
enabled: true
version: "21.3.8.16"
version: "23.0.2"
yum:
baseurl: https://dl.bintray.com/rabbitmq-erlang/rpm/erlang/21/el/6
repo_gpgcheck: true
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/erlang_package/pinned_rpm
......@@ -470,7 +479,7 @@ suites:
enabled: true
zypper:
baseurl: https://download.opensuse.org/repositories/network:/messaging:/amqp/openSUSE_Leap_15.1/
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/erlang_package/latest_rpm
......
......@@ -40,9 +40,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
virtualhosts:
- vhost1
- vhost2
......@@ -83,9 +83,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/management_plugin
......@@ -100,9 +100,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
systemd:
limits:
NOFILE: 54000
......@@ -119,9 +119,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "21.3.8.16-1"
version: "23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -152,9 +152,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "21.3.8.16-1"
version: "23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
systemd:
limits:
NOFILE: 54000
......@@ -171,9 +171,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -188,9 +188,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -205,9 +205,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "21.3.8.16-1"
version: "23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -222,9 +222,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
attributes:
apt:
confd:
......@@ -233,9 +233,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -253,9 +253,9 @@ suites:
erlang:
install_method: "esl"
esl:
version: "1:21.3.8.16-1"
version: "1:23.0.2-1"
rabbitmq:
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/integration/default
......@@ -382,7 +382,7 @@ suites:
enabled: true
zypper:
baseurl: https://download.opensuse.org/repositories/network:/messaging:/amqp/openSUSE_Leap_15.1
version: "3.7.26"
version: "3.8.5"
verifier:
inspec_tests:
- test/erlang_package/latest_rpm
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment