Commit 88bdb2a3 authored by jtimberman's avatar jtimberman
Browse files

release v1.3.0

parent 8d637c2b
## v1.3.0:
This cookbook now has support for Test Kitchen 1.0 (alpha). See
TESTING.md in the git repo.
### Bug
- [COOK-2595]: erlang cookbook now incorrectly depends on apt <= 1.7.0
- [COOK-2894]: erlang::esl uses nil attribute
### Improvement
- [COOK-2509]: Add support for installing Erlang/OTP from Erlang
Solutions' repositories
## v1.2.0:
* [COOK-2287] - Add support for installing Erlang from source
......
This cookbook includes support for running tests via Test Kitchen (1.0). This has some requirements.
1. You must be using the Git repository, rather than the downloaded cookbook from the Chef Community Site.
2. You must have Vagrant 1.1 installed.
3. You must have a "sane" Ruby 1.9.3 environment.
Once the above requirements are met, install the additional requirements:
Install the berkshelf plugin for vagrant, and berkshelf to your local Ruby environment.
vagrant plugin install vagrant-berkshelf
gem install berkshelf
Install Test Kitchen 1.0 (unreleased yet, use the alpha / prerelease version).
gem install test-kitchen --pre
Install the Vagrant driver for Test Kitchen.
gem install kitchen-vagrant
Once the above are installed, you should be able to run Test Kitchen:
kitchen list
kitchen test
......@@ -3,7 +3,7 @@ maintainer "Opscode, Inc."
maintainer_email "cookbooks@opscode.com"
license "Apache 2.0"
description "Installs erlang, optionally install GUI tools."
version "1.2.0"
version "1.3.0"
depends "apt", ">= 1.7.0"
depends "yum", ">= 0.5.0"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment