Unverified Commit 6507ebb7 authored by Ben Abrams's avatar Ben Abrams
Browse files

if package version is specified pin version on debian when using esl


Signed-off-by: default avatarBen Abrams <me@benabrams.it>
parent 2289d250
......@@ -31,6 +31,14 @@ when 'debian'
action :add
end
apt_preference 'erlang_solutions_repo' do
package_name 'esl-erlang'
pin "version #{node['erlang']['esl']['version']}"
pin_priority 700
action :add
not_if { node['erlang']['esl']['version'].nil? }
end
package 'esl-erlang' do
version node['erlang']['esl']['version'] if node['erlang']['esl']['version']
end
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment