Commit 3579810b authored by Tim Smith's avatar Tim Smith
Browse files

Require Chef Infra Client 12.15+ & resolve Cookstyle issues



If you're still running EOL Chef Infra Client you can at least get to
12.15. Technically 15+ is the only supported release, but it's easy
   enough to require this.
Signed-off-by: default avatarTim Smith <tsmith@chef.io>
parent 49272337
......@@ -10,9 +10,9 @@ Install Chocolatey with the default recipe.
- Windows
### Chef
### Chef Infra Client
- 12.7 or greater
- 12.15 or greater
## Notes
......
......@@ -3,7 +3,6 @@ maintainer 'Guilhem Lettron'
maintainer_email 'guilhem.lettron@youscribe.com'
license 'Apache-2.0'
description 'Install Chocolatey on Windows'
long_description 'Installs the Chocolatey package manager for Windows.'
version '2.0.1'
source_url 'https://github.com/chocolatey/chocolatey-cookbook'
......@@ -11,4 +10,4 @@ issues_url 'https://github.com/chocolatey/chocolatey-cookbook/issues'
supports 'windows'
chef_version '>= 12.7' if respond_to?(:chef_version)
chef_version '>= 12.15'
#
# Cookbook Name:: chocolatey
# Cookbook:: chocolatey
# recipe:: default
# Author:: Guilhem Lettron <guilhem.lettron@youscribe.com>
#
# Copyright 2012, Societe Publica.
# Copyright 2015, Doug Ireton
# Copyright:: 2012, Societe Publica.
# Copyright:: 2015, Doug Ireton
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
......@@ -22,7 +22,7 @@ unless platform_family?('windows')
return "Chocolatey install not supported on #{node['platform_family']}"
end
Chef::Resource.send(:include, Chocolatey::Helpers)
Chef::Resource.include Chocolatey::Helpers
install_ps1 = File.join(Chef::Config['file_cache_path'], 'chocolatey-install.ps1')
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment