Commit fe0dc82f authored by Rhea Ghosh's avatar Rhea Ghosh

make updates to be able to use amazon linux

parent a591128f
......@@ -12,7 +12,7 @@ default['blackfire']['php']['log_file'] = nil
default['blackfire']['php']['server_id'] = nil
default['blackfire']['php']['server_token'] = nil
if platform_family?('rhel', 'fedora')
if platform_family?('rhel', 'fedora', 'amazon')
default['blackfire']['php']['ini_path'] = '/etc/php.d/zz-blackfire.ini'
elsif platform?('debian') && node['platform_version'].to_f < 7.0
default['blackfire']['php']['ini_path'] = '/etc/php5/conf.d/blackfire.ini'
......
......@@ -10,7 +10,7 @@ include_recipe "#{cookbook_name}::repository"
agent_version = node[cookbook_name]['agent']['version'] ? node[cookbook_name]['agent']['version'] : Blackfire::Versions.agent(node)
agent_version << '-1' if platform_family?('rhel', 'fedora')
agent_version << '-1' if platform_family?('rhel', 'fedora', 'amazon')
package 'blackfire-agent' do
version agent_version
......
......@@ -20,7 +20,7 @@ end
probe_version = node[cookbook_name]['php']['version'] ? node[cookbook_name]['php']['version'] : Blackfire::Versions.probe(node)
probe_version << '-1' if platform_family?('rhel', 'fedora')
probe_version << '-1' if platform_family?('rhel', 'fedora', 'amazon')
package 'blackfire-php' do
version probe_version
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment